August 23, 2019, 02:14:35

Author Topic: Problems with Luminescence maps/lamp maps  (Read 2364 times)

Offline USSCrazybat

  • Recruit
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Problems with Luminescence maps/lamp maps
« on: March 01, 2017, 16:14:05 »
I've been tinkering with the textures in the Star Trek EAC mod in order to get a feel for how Nexus accepts textures, and have been working on two ships - the Prometheus and the Saber. When the mod was first installed, both ships seemed be covered in one singular white glow as opposed to only the engines, spotlights and impulse engines. I have managed to fix the Saber class by inverting the alpha channels on its main textures, however the method does not seem to work for the Prometheus. Furthermore, in my experimentation with the Galaxy class, I attempted to add glows to another part of the ship by modifying the alpha channel, but there was limited change.

Are the lamps/lum maps tied to the mesh in any way, or can I still fix this using a texture editor? I'm having some trouble working out meshes atm, so focusing on texture editing would be preferable. 

Offline The Old Dragon

  • Ensign
  • ***
  • Posts: 362
  • Karma: 6
    • View Profile
    • http://
Re: Problems with Luminescence maps/lamp maps
« Reply #1 on: March 03, 2017, 09:50:58 »
Hi USSCrazybat,

Good to see some new interest here, can't say too much right now as I've got to go to work (will try to help more later). Nexus does accept various texture maps but they need to be applied during the converting process.

The texture files start off as .tga files (your main colour map and any additional ones such as bump, lum, alpha,etc), these are then fed into Nexus's converting tool and turned into .tex files. So unless you have access to the original art files, it'll mean re-working them completely.
Better to look the fool by asking, then prove them right with ignorance.

Offline USSCrazybat

  • Recruit
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Problems with Luminescence maps/lamp maps
« Reply #2 on: March 03, 2017, 16:03:45 »
Thanks for your reply. It turns out that whilst the textures I was editing were of a Prometheus Class ship, they were not the textures of the Prometheus Class currently in use in the game - which were under a far more innocuous name. Once I inverted the alpha map of the .tga and reconverted it, it works and looks perfectly.

By the way, do you know of any reason for the lettering on the ships to be reversed? In the original texture file the text reads the proper way, but in game it's mirrored. I had to mirror the text in the texture itself to get it facing the right way.
« Last Edit: March 03, 2017, 16:09:13 by USSCrazybat »

Offline The Old Dragon

  • Ensign
  • ***
  • Posts: 362
  • Karma: 6
    • View Profile
    • http://
Re: Problems with Luminescence maps/lamp maps
« Reply #3 on: March 03, 2017, 23:56:31 »
Glad you got the map sorted out, without seeing the model with reversed lettering all I can surmise is it's something in the way they made the model.
Better to look the fool by asking, then prove them right with ignorance.

Offline USSCrazybat

  • Recruit
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Problems with Luminescence maps/lamp maps
« Reply #4 on: March 04, 2017, 01:11:00 »
Looks like the only way to fix the text is to reverse the text in the .tga itself. I've fixed both the Saber and Prometheus glows and texts. Given their unreversed alpha maps and text as well as lack of hardpoints compared to the other ships in the mod, it looks like these two were just direct conversions from Bridge Commander. I'm going to see if I can hardpoint them myself. They're the highest quality Prometheus/Saber meshes out there that I know of - if I am going to do my own Star Trek mod those will probably carry over.

Offline The Old Dragon

  • Ensign
  • ***
  • Posts: 362
  • Karma: 6
    • View Profile
    • http://
Re: Problems with Luminescence maps/lamp maps
« Reply #5 on: March 04, 2017, 11:12:39 »
With regards to doing the model parameters, there is a guide here...
http://nexusthegame.net/wiki/Guide_to_Modelling_Parameters
As always, feel free to ask questions here.
Better to look the fool by asking, then prove them right with ignorance.

Offline USSCrazybat

  • Recruit
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Problems with Luminescence maps/lamp maps
« Reply #6 on: March 07, 2017, 03:13:06 »
Thanks for your help so far. I just managed to recently convert a high-poly model over from Bridge Commander - but a small portion of the ship is completely black. It seems to be an issue with just this model, as I ported over another ship afterward and it had no such issues. Would you have any suggestions? I've checked the .tex files and there doesn't seem to be any alteration to the images themselves.
« Last Edit: March 07, 2017, 03:23:06 by USSCrazybat »

Offline The Old Dragon

  • Ensign
  • ***
  • Posts: 362
  • Karma: 6
    • View Profile
    • http://
Re: Problems with Luminescence maps/lamp maps
« Reply #7 on: March 07, 2017, 17:30:01 »
Wow, nice model. The first thought that comes to mind is the actual texture size in pixels, Nexus prefers them to be square and by standard 'RAM' sizes (64x64, 128x128, etc up to 2048x2048 (though I think it can do 4096)).

Other than that, maybe the UV map got corrupted during conversion? I think I'd need to get my hands on the files and play around a bit to figure it out.
Better to look the fool by asking, then prove them right with ignorance.

Offline USSCrazybat

  • Recruit
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Problems with Luminescence maps/lamp maps
« Reply #8 on: March 07, 2017, 18:13:51 »
Do you mind if I send the files over? I'm still figuring this all out.

Offline The Old Dragon

  • Ensign
  • ***
  • Posts: 362
  • Karma: 6
    • View Profile
    • http://
Re: Problems with Luminescence maps/lamp maps
« Reply #9 on: March 07, 2017, 21:28:10 »
By all means, I'll pm you.
Better to look the fool by asking, then prove them right with ignorance.

Offline USSCrazybat

  • Recruit
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Problems with Luminescence maps/lamp maps
« Reply #10 on: March 09, 2017, 00:46:56 »
Some beauty shots of the Century Class thanks to Old Dragon helping me out with a misaligned texture map and spec maps.